lunes, 27 de agosto de 2012

ENUNCIADOS DE REPETICIÓN 


algunos pre-conceptos son:


Contador: Es un área de trabajo cuyo incremento o decremento es definido.El termino contador esta asociado con la acción de contar.

Acumulador: Área de trabajo donde se almacena un valor que puede ser variable. El termino acumulador viene de acumular (sumar cantidades).

Promedio: Es el resultado de la división de la suma de unas variables (acumulador) dividida por el numero de variables sumadas (contador).
Promedio= acumulador/contador
                 
Registro centinela: Es el ultimo registro que contiene una señal de fin de archivo, no se procesa. Cuando se utiliza el registro centinela se debe leer antes del ciclo el primer registro, una vez se procese este se realiza la lectura del siguiente (antes del fin de ciclo). No hay que utilizar contador para controlar el final del ciclo.

Registro identificador: Indica el numero de repeticiones que deben realizarse en un ciclo. se lee antes del ciclo, necesita de un contador para controlar cuando se terminan de procesar todos los registros indicadores en el registro identificador.

Ciclos

Los ciclos son las herramientas que permiten implementar acciones que se deben ejecutar repetidamente, repetir varias veces una serie de acciones o instrucciones.

existen tres estructuras repetitivas:
1. haga mientras
2.repetir hasta
3.desde o para. 


Ciclo: Hacer mientras


Se utiliza para ejecutar repetitivamente un conjunto o bloque de instrucciones mientras que se cumpla con una condición especifica, es decir, ejecuta repetidamente las instrucciones hasta que una variable contador llegue a su valor limite.

sintaxis:

mientras < condición > hacer
<secuencia de instrucciones>
<actualizar>
fin mientras

esquema general:

inicio
inicializar contador
lea el numero de interaciones 
mientras < condición >haga
lea <registro de datos>
      <procese>
fin mientras
fin

ejemplo:
Hacer un algoritmo que sume los 5 primeros números naturales.

análisis del problema   
                                                              
piden-suma de los primeros 5 números naturales                                
tengo-no tengo nada, el programa genera los números                        
como-acumulador


definición de variables


num-números-entero
sum-suma-real



inicio
sum<-0
num<-0
mientras (num<5)haga
num<-num+1
sum<-sum+num
fin mientras
escriba "la suma es:",sum
fin





                                                               Ciclo: Hacer para 


Consta básicamente de dos partes, La primera: la palabra Para seguida de la iniciación de una variable, la determinación del máximo valor que puede tomar la variables iniciada, y la cantidad a incrementar después de cada ciclo a dicha variable; y la palabra Haga.
La segunda: esta compuesta por las palabras Fin para, que indican hasta que enunciados hay que repetir, indicando el rango del Haga Para.


Formato o sintaxis del haga Para. 

Para I=1 hasta N, con incrementos K haga
                 bloque de instrucciones
fin para

El enunciado haga para ejecuta intrínsecamente y a su debido tiempo 3 acciones:

1. Inicializa la variable I en el valor 1, que puede ser una variable o una constante.
2. Incrementa la variable I en el valor K, que puede ser una variable o una constante, cuando el incremento es de a uno esta parte puede suprimirse.
3. Controla el valor de la variable I para verificar si ha superado el valor de N, para determinar si se repiten los enunciados nuevamente o se continua después del fin para.

ejemplo: 

Calcular los cuadrados de los 10 primeros números e imprimirlos.

inicio
para J =1 hasta 10,1 haga
cuad<-J* J
mostrar " el numero es:", J
mostrar " su cuadrado es:", cuad
fin para
fin




Haga para anidados: Es cuando un ciclo se encuentra dentro de otro.

ejemplo: elabore un programa que muestre la siguiente salida:
11111
22222
33333
44444
55555
         


                                                                               
inicio
para K =1 hasta 5 haga
para J =1 hasta 5 haga












No hay comentarios:

Publicar un comentario en la entrada